skar

When I launch Spine I get a message saying
Screen%20Shot%202021-02-26%20at%206.33.33%20PM.png


I check the log -
Screen Shot 2021-02-26 at 6.35.52 PM.png
You do not have the required permissions to view the files attached to this post.
skar
  • Posts: 3

Nate

Yep, as it says, your Spine installation is out of date and you'll need to download and reinstall Spine.

We made some great improvements to the Spine launcher. That is the part that not only shows the launcher window and starts the Spine editor, but is also the foundation that the Spine editor runs on top of. The improvements make Spine a lot faster, both start up and the editor itself. In some cases it's more than 20% faster! Unfortunately the improvements mean that editor versions 4.0.55-beta and later require reinstalling Spine.

We have a nicer dialog that explains it better and links to this page:
Spine: Reinstallation
However, this was the first time we needed that dialog and it had a bug, so we couldn't use the dialog this time. It'll work next time, if we ever need it again! We try not to require launcher reinstallation, but sometimes it can't be avoided.
User avatar
Nate

Nate
  • Posts: 10741

skar

Hmm, I downloaded the installer from my license page and reinstalled with the same problem. I’m using the Mac client.
skar
  • Posts: 3

Nate

Can you post your entire spine.log file? The first line should be Spine Launcher 4.0.27.
User avatar
Nate

Nate
  • Posts: 10741

skar

Spine Launcher 4.0.24
Esoteric Software LLC (C) 2013-2021 | http://esotericsoftware.com
Mac OS X x86_64 10.16
ATI Technologies Inc., AMD Radeon RX 5600 XT OpenGL Engine, 2.1 ATI-4.2.15
Downloading: Spine 4.0.57-beta Professional
ERROR: Unable to download: Spine installation out of date. Please reinstall Spine.
[error]
[caller]
at s.edM.L(_:453)
at s.edM.B(_:314)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
at s.Ogo.L(_:215)
at s.sGN.L(_:432)
at s.Ogo.F(_:111)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Cause: [io] Server returned HTTP response code: 400 for URL: https://usapi.esotericsoftware.com:443
at jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at jdk.internal.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at jdk.internal.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstanceWithCaller(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection$10.run(Unknown Source)
at java.security.AccessController.doPrivileged(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getChainedException(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(Unknown Source)
at s.Ogo.L(_:160) ...
Cause: [io] Server returned HTTP response code: 400 for URL: https://usapi.esotericsoftware.com:443
at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
at java.net.HttpURLConnection.getResponseCode(Unknown Source)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(Unknown Source)
at s.Ogo._(_:287)
at s.Ogo.L(_:129) ...

---

Ok, thanks Nate, I again redownloaded the latest dmg from my license page and this time it worked, upgraded to launcher 4.0.27

I think maybe this happened because I didn't delete the previous version of Spine that I had installed and moved to a different folder than the default Application folder
skar
  • Posts: 3

Nate

Cool, glad that worked! :)
User avatar
Nate

Nate
  • Posts: 10741


Return to Bugs