nicmar

After I apply a prefab that has a Spine skeleton, i still get this when checking the apply prefab button.
Why is that? It's hard to know if i made any changes or not.


If i review what has changes, it looks like this:
We're making SpaceChef with Spine. An action filled cooking adventure. We're coming soon to Kickstarter, sign up for our newsletter to be the first to get notified: www.spacechefgame.com. Follow our work on Twitter @BlueGooGames.
User avatar
nicmar
  • Posts: 148

Harald

User avatar
Harald

Harri
  • Posts: 4459

nicmar

Thanks. I didn't even realize there were Spine Preferences in Unity! :)
However, I'm not sure if I'm doing this the right way, I still have the problem, see this video:
https://youtu.be/d8iTtrtFh_E

What I'm selecting between these inspector changes is the root object that the spine skeleton is a child of.

It seems to ignore both "Use global" and "enabled". It was set to disabled before.
We're making SpaceChef with Spine. An action filled cooking adventure. We're coming soon to Kickstarter, sign up for our newsletter to be the first to get notified: www.spacechefgame.com. Follow our work on Twitter @BlueGooGames.
User avatar
nicmar
  • Posts: 148

Harald

Hm, this seems strange indeed. Did you enable the global setting Prefabs Fix Prefab Overr. MeshFilter. in the Spine Preferences as well? I'm just asking since it was not included in your video.

If so, which verison of the spine-unity runtime are you using (name of the unitypackage, also listed in Assets/Spine/version.txt)?
User avatar
Harald

Harri
  • Posts: 4459


Return to Unity